Hydro leaking but cant locate

Steve

LawnSite Bronze Member
Location
NE FL
Im running a 48" Exmark pioneer. Around early November when we had our first real cold (north Florida) the right steering arm seemed a little tight/sluggish, I figured it was the cold weather and it would loosen back up but it never did. I then noticed I had a small oil stain on my trailer deck under the right hydro, so I took it to a shop. They couldn't find any leaks but said the dampener needed replacing, so they replaced it. When I got it back both control arms were firm in the steering. About 10 hours afterwards I lost steering. The new belt I put on around September or October had come off and had some shredding too it, the reason I had to put a new belt was because one of the pulleys went out and the belt was snapped. I have the mower sitting on the front of the trailer at the moment were deck is clean and once again I have an oil stain under the right hydro, but I can't find any place were it might be leaking from.

Any suggestions?
 

MowDaddy

LawnSite Fanatic
Location
Grand Rapids, MN
Im running a 48" Exmark pioneer. Around early November when we had our first real cold (north Florida) the right steering arm seemed a little tight/sluggish, I figured it was the cold weather and it would loosen back up but it never did. I then noticed I had a small oil stain on my trailer deck under the right hydro, so I took it to a shop. They couldn't find any leaks but said the dampener needed replacing, so they replaced it. When I got it back both control arms were firm in the steering. About 10 hours afterwards I lost steering. The new belt I put on around September or October had come off and had some shredding too it, the reason I had to put a new belt was because one of the pulleys went out and the belt was snapped. I have the mower sitting on the front of the trailer at the moment were deck is clean and once again I have an oil stain under the right hydro, but I can't find any place were it might be leaking from.

Any suggestions?

Does your hydro reservoir go down? If not its probably eng oil leaking a bit, or spillage.
It may follow the frame or a cable then drip near hydro.
 

Top Forums



Top