John Deere Z520A Hour Meter issue

amherst33

LawnSite Member
Location
Amherst WI
Hello,
Recently I had to replace my Kohler 25 HP engine on my 2008 JD Z520A. The original engine was the Kohler Courage and I upgraded to the 25 HP Kohler Confident. The wire harness plug from the new engine was a direct plug in to the existing chassis harness. There are only a few wires to the plug: red for the fuel shutoff solenoid, white to ground the coils, and a blue for the starter solenoid.
Everything functions as it should and the mower runs, charges, and operates correctly. The problem is that the hour meter does not advance. It is showing the actual hours but will not accumulate during mow time. I replaced the hour meter with a genuine JD part and the same thing. Shows 0.0 hours and will not advance. I am almost certain the meter was working correctly prior to the old engine locking up.
The new engine does have an oil pressure switch where as the old one didn't but again, the chassis harness does not accommodate wiring for an oil pressure switch and it ran without one before.
What am I missing? Scouring the internet has got me nowhere. Thanks!
 

JoeRagMan

LawnSite Senior Member
Location
Near TMI
While wiring the hour meter through the oil pressure switch is the preferred way, if that is not possible, could you wire the hour meter to the “ run” circuit on the ignition switch? As long as you don’t forget to turn the ignition switch to the “off” position, it should work. Good Luck.
 

Breezmeister

LawnSite Gold Member
Location
South Jersey
What am I missing? Scouring the internet has got me nowhere. Thanks!


Do you know how many terminals you have on your ignition switch, 5 or 6 ?
.
 
OP
A

amherst33

LawnSite Member
Location
Amherst WI
The ignition switch has 4 wires. The hour meter also has 4 wires.
20210801_084545.jpg
 

Attachments

  • 20210801_084612.jpg
    20210801_084612.jpg
    386.9 KB · Views: 12

Breezmeister

LawnSite Gold Member
Location
South Jersey
You have a 6 tab ignition switch. Most manufactures use the tab I circled for the hour meter, pto etc. Look for a single connector that may go to it, it may have vibrated off, it may have more then one wire. It should be hot with the key in the on position, but that is what you should connect to.


Ignition.jpg

.
 
OP
A

amherst33

LawnSite Member
Location
Amherst WI
That tab is covered with the yellow wire as seen in the second pic. The hour meter has power and shows 0.0 hours but will not advance when running.
 

Top Forums



Top