Just got an X mark / Toro spreader sprayer I'm excited any and all tips welcome

Discussion in 'Pesticide & Herbicide Application' started by HenryB, Apr 10, 2019.

  1. lawndude28

    lawndude28 LawnSite Senior Member
    Messages: 320

    Look into 4 score from siteone. Similar to t-zone, in fact I think PBI blends 4 score for lesco, but its about .5 a k to run. Ran it last fall and had very good results.
     
  2. JunkmanJoe

    JunkmanJoe LawnSite Member
    Messages: 30

    Thank you lawn dude I will.
     
  3. RigglePLC

    RigglePLC LawnSite Fanatic
    Messages: 16,095

  4. americanlawn

    americanlawn LawnSite Fanatic
    from midwest
    Messages: 6,086

    Check the "pathway" of the cable ..make sure it is the "path of least resistance". Then check cable end adjustment. Also make sure the (accuway) "slide plate" is not warped, cuz they can wear out. Make sure the (plastic) "tracks" of the (stainless steel) plate are not gummed up with fert. Bottom line >> anytime a "cable" is relied upon... issues arise. I don't like cables, cuz Fluid Film can only do so much.
     
    hort101 likes this.
  5. ed2hess

    ed2hess LawnSite Fanatic
    Messages: 16,000

    Any pictures?
     
  6. RigglePLC

    RigglePLC LawnSite Fanatic
    Messages: 16,095

    If it is a cable problem--any mower shop can replace that cable with a new--better--premium-type actuator cable.
    Thanks, Larry. Yes--check that the slide is not binding, gummed up or warped in some way. Work a little Fluid film into each end of the cable.
     
    hort101 and americanlawn like this.
  7. americanlawn

    americanlawn LawnSite Fanatic
    from midwest
    Messages: 6,086

    Thanks Riggle -- I hate "cables" in the first place. Side note: we have replaced "original" TURFCO parts with >> "stainless steel" bolts, nuts, washers, etc. Also - we switched to "Kevlar" belts, cuz they last 3 times longer. Keep in mind that TURFCO has not been in the "spray business" very long.
     
  8. docjones

    docjones LawnSite Member
    from WV
    Messages: 199

    Can someone tell me what their getting square foot coverage with these toro/exmark spreader/sprayer in 20 gallon tank using standard teejet tips that came with machine and at what psi?
     
  9. That Guy Gary

    That Guy Gary LawnSite Gold Member
    Messages: 3,052

    With the stock white tips I cover 60k with a full tank at 30 psi.
     
  10. grass4gas

    grass4gas LawnSite Senior Member
    Messages: 818

    It also depends on your speed. When I calibrated the output, it took me 30 seconds to cover 1000 square feet. I’m pushing out .5 gal/1000 with the white tips at 40 psi at that speed which is what I wanted. I like a heavier volume. I only broadcast lawns that need it. Majority of the time I am spot spraying. I also don’t do really big lawns. My largest is just under an acre
     

Share This Page