1. Missed the live Ask the Expert event?
    Catch up on the conversation about fertilization strategies for success with the experts at Koch Turf & Ornamental in the Fertilizer Application forum .

    Dismiss Notice

Kohler 12.5 no spark, tried 3 coils, ugh

Discussion in 'Mechanic and Repair' started by shopteacher, Jul 27, 2008.

  1. shopteacher

    shopteacher LawnSite Member
    Messages: 60

    Hey guys, what's up?
    I have a Kohler cv 12.5 and it has no spark. It was running and mowing within the last day. I tried another used coil, still no spark, Then I tried a third used coil, still no spark.

    When I put the used coils back on their original engines, they have spark. What gives?

    I disconnected the ground wire from the coil to eliminate all wiring problem possibilities. I also got a faint spark a couple of times.

    I would consider myself a decent mechanic, so I don't think I am overlooking anything, but why would an engine not have spark with a good coil. I even tried 2 different flywheels.

    The magnet on the flywheel is still magnetic, and I know I am cranking her at at least 55o rpm. Any thoughts?????????????
  2. Partsangel

    Partsangel LawnSite Member
    Messages: 80

    I understand your plight, I had a Tecumseh HH just put me threw the ringer! and as always it turns out to be something simple I over looked :hammerhead: anyway about your coils that work on one engine but not another? well its very possible that the posts where the coil fits on the engine your trying to fix have a little bit of rust on them. Try using a wire brush on the posts and the coil where they meet and brush the Sh (well you know what I mean) out of those areas and retry with out connecting the kill wire. I would also double check and make sure your not putting the coil upside down and also most electronic coils wont fire unless the engine is turning at least 700 rpms.

    I hope this helps.
  3. kawasaki1

    kawasaki1 LawnSite Member
    Messages: 108

    what he said.^
  4. sawman65

    sawman65 LawnSite Senior Member
    Messages: 754

    do you have a spark advance module on you unit? need model # to help
  5. shopteacher

    shopteacher LawnSite Member
    Messages: 60

    This model does have a regulator on it, but if I disconect the wire so it is just the coil, there should be a spark.

    I have filed and thouroughly cleaned all surfaces and have double, triple, quadrupe checked everything.

    This is becoming a quest that I cannot let die. I must know why this engine will not produce a spark.

    The only thing I can figure is the flywheel, which is not the original one, is somehow bad

    Help, save a man from a slow agonizing frustration state of mind. The next thing you will see from me is an inability to type and spel corekly.
  6. Phil G

    Phil G LawnSite Senior Member
    Messages: 844

  7. Partsangel

    Partsangel LawnSite Member
    Messages: 80

    If your engine has a spark advance module on it they have to be connected in order to receive a spark, like sawman65 said....
    we need your Model and Spec numbers to really help you...And We Want To Help You....Promise.

  8. shopteacher

    shopteacher LawnSite Member
    Messages: 60

    Found the problem. The coil (ignition module) was upside down.

    The motor I took the coil from had it that way so I just installed it the same way.
    I learned from the experience which is all that counts.

    Thanks for your help and attempt at straightening out one guy's ignorance.

    I speak softly, but carry a big set of tools.
  9. Phil G

    Phil G LawnSite Senior Member
    Messages: 844

    D'oh. Well done for persevering. Don't it feel good to have a result after all that trouble?
    atb Phil


Share This Page