Kohler m18 still no fuel

Discussion in 'Mechanic and Repair' started by diggerdave65, Nov 9, 2009.

  1. diggerdave65

    diggerdave65 LawnSite Member
    Messages: 21

    Hi All -- Im back again and at a complete loss -- need some help on a kohler M18QS spec 24696, in my bobcat skid loader. Here are the details. Machine died in middle of use. Looks like it is not getting fuel (disconnected line into carb and cranked the engine, no fuel comes out.) So I replace the manual fuel pump. Still no fuel. Here is the odd thing -- I took an extra tank I had and rigged it so that its fuel line trickled directly into the carb via the air cleaner opening and sure enough the loader will run all day long that way. I can also dump a splash of fuel directly into the carb and it will run till it uses that fuel up. When I replaced the fuel pump I discovered an IN LINE electric shut off switch. (Century Shut Off Valve Model LLG). Thinking that was the problem I bypassed it completely and still no fuel will come out at the carb when you crank the engine. Someone here I think mentioned a stuck float valve?? Is that enough to cause this??? If so how come it runs when I trickle gas into the venturi?? Can someone help me understand /solve this please!! thanks in advance- dave
  2. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    OK Dave,

    If you are getting no fuel through this new pump disconnect the fuel line from the tank at the pump, Then hook your test tank to the pump and check for fuel at the carb fuel line (put a container under this line).

    If you now have fuel to the carb check for a restriction in the line from the pump to the tank, There should be a fuel filter between these two that could be plugged up.

    If you still have no fuel to the carb fuel line with the test tank hooked to the pump inlet fitting you could have a worn pump activation lobe on the camshaft.

    It's not likely the float stuck closed while running, There's just too much vibration and movement in the machine. I have seen trash/rust clog the fuel inlet fitting on the carb and inlet seat port which caused no fuel to enter the bowl, But check the above first which doesn't require tearing anything apart.

    BTW, Dropping fuel into the throat of a carb only tells you the engine has spark and there is no mechanical issues to keep it from running.

    Good Luck
  3. ricky86

    ricky86 LawnSite Silver Member
    Messages: 2,058

    Does it have an aux electric fuel pump on it?
  4. diggerdave65

    diggerdave65 LawnSite Member
    Messages: 21

    Rob-- you were spot on-- THANKS! -- long story short, I did what you said bypassing everything with the spare fuel tank and she runs fine. So I pop out the rubber grommet and fuel fitting on the top of the skid loaders tank and sure enough -- there is NO fuel pickup line attached to the fitting stub.. it is at the bottom of the tank....Priceless!!! I had to laugh at myself. Anyway, lesson learned after many hrs and skinned knuckles spent swapping out the fuel pump (yeah it is on the inboard side which meant no room at all...) -- start with the easy/logical stuff first. At least i got a new fuel delivery sys and took the time to change out all filters, belts, plugs etc etc while I was in there.. thanks again!
  5. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    Yep, When the pump went on the M18 in my Z;


    I looked down in that hole and said "I ain't goin there" !!!

    I screwed the oil fill pipe out of the block drilled a 1/4" hole in the side and welded a fuel hose fitting over the hole then screwed it back in, It now has a $15 impulse pump mounted to the frame..... :dancing:

    Glad to hear you found the problem..... [​IMG]

Share This Page