1. Missed the live Ask the Expert event?
    Catch up on the conversation about fertilization strategies for success with the experts at Koch Turf & Ornamental in the Fertilizer Application forum .

    Dismiss Notice

Lesco Walk Behind Not Moving

Discussion in 'Mechanic and Repair' started by vinny_a, Apr 28, 2010.

  1. vinny_a

    vinny_a LawnSite Member
    from PA
    Messages: 20

    So I recently bought a 48" Lesco hydro walk behind and now I'm having some issues with it. It mowed great for a couple weeks then a few days ago it was having some problems going up hills and the mower just seemed slow all around. Now it wont move at all when I turn it on, not even a bit of a creep. I checked the hydro oil and replaced the filter today, and still nothing at all.

    Any help would be greatly appreciated. Also if anyone has the manuals to the mower and pumps that would be great as I cant find them. The labels on the pumps say Hydro gear BDP-10L-117P (left pump) and Hydro gear BDP-10L-504 (right pump). I also dont know the name of the mower but I was able to get the model # off the mower and it is: MD10101065
     
  2. unkownfl

    unkownfl LawnSite Gold Member
    Messages: 3,837

    Check the belts?
     
  3. vinny_a

    vinny_a LawnSite Member
    from PA
    Messages: 20

    What belts?
     
  4. unkownfl

    unkownfl LawnSite Gold Member
    Messages: 3,837

    The one that turns the pumps... Look under the engine. Make sure the belt going to the pumps is tight or still there.
     
  5. unkownfl

    unkownfl LawnSite Gold Member
    Messages: 3,837

    ever figure it out?
     
  6. vinny_a

    vinny_a LawnSite Member
    from PA
    Messages: 20

    I haven't gotten a chance to look at it yet, I'll probably get a chance to look at it on saturday. I'll let you know what I find when I look then. Thanks for the help too.
     

Share This Page