Mower Running Rich

Rain Man av

LawnSite Member
Location
Leander, TX
Briggs 28N707 1118-E1

Was running ok few months ago, neighbor removed air cleaner left if off and rains started - Carb filled with water. Removed carb and spark plug blew out water and changed oil. Cleaned carb - nikki - and reinstalled, mower is running very rich. Low speed seems not so bad, but gas er up and she puffs black smoke if I choke her just a little, it gets worse. Took off nikki and installed a walbro. same issue. No adjustment on carb solves issue.

Gas is 93 octane. Where do I go next ?
 

dutch1

LawnSite Silver Member
Location
Jayhawk
Have you checked your oil level? It possible that water may have run through the carb and into the block thereby raising the oil level to the point that the engine is over filled--possibly burning excess oil.
 
OP
R

Rain Man av

LawnSite Member
Location
Leander, TX
compression test will not resolve issue of running rich. compression test will tell you why your mower has no power if it runs badly. Poor compression results in an inability to draw in fuel making for lean running condition, or won't start, won't stay running condition. If too much compression, then engine is hard to start. I don't have either of those problems. The other possible reason for running rich is a stuck needle or float issue. I ruled both out.

As it turns out, on both carbs the small jet screw was missing. I robbed one off another carb and it now runs fine.
 

piston slapper

LawnSite Platinum Member
Location
Tampa Fl
Replace the sparkplug. Remove the air filter...shut off or pinch off the fuel.
See how it runs.....let it run till it shuts off...then turn on the fuel and see how it runs.

Dutch......could be time for a little snakeoil......Hmmmmm....
Posted via Mobile Device
 

piston slapper

LawnSite Platinum Member
Location
Tampa Fl
compression test will not resolve issue of running rich. compression test will tell you why your mower has no power if it runs badly. Poor compression results in an inability to draw in fuel making for lean running condition, or won't start, won't stay running condition. If too much compression, then engine is hard to start. I don't have either of those problems. The other possible reason for running rich is a stuck needle or float issue. I ruled both out.

As it turns out, on both carbs the small jet screw was missing. I robbed one off another carb and it now runs fine.
Hmmmm........
Posted via Mobile Device
 

Top