1. Site Upgrade Planned for Next Week!

    LawnSite community,

    As you know, we continually look for ways to enhance your experience on LawnSite and always try to make the site better, with more enhanced features and capabilities, and improved navigation so you can easily find the information that you’re looking for. So, the time has come for another software/site upgrade to a newer version of our platform. Once the upgrade is complete, we’re planning on making additional changes that will significantly improve upon your experience on LawnSite.

    The upgrade is planned for early next week, with additional features being rolled out in the weeks and months ahead. As always, we welcome your feedback and look forward to hearing your thoughts.
    Dismiss Notice

Much weirdness with a ZD326P Mower

Discussion in 'Mechanic and Repair' started by Murf, Jun 29, 2020.

  1. Murf

    Murf LawnSite Member
    Messages: 1

    As the title states. I recently 'inherited' a ZD326P ZTR mower from a now former sub-contractor.

    It does some really weird stuff, some I've figured out, some has everybody I've asked scratching their heads. Hopefully the collective brain trust here can assist.

    The one really annoying mystery is the red Charge Indicator in the Easy Checker panel. It will intermittently flicker right from a cold start. Battery is good. Flickering almost seems to be related to moving / bumps / etc. but not always and after running for a bit the flickering becomes longer pulses eventually becoming a steady on light. Here's the twist, we've put both a volt meter and it IS charging at about 13.5 - 13.8 volts. No loose / sketchy wires that we could find. Any ideas?

    Now the other strange one is that someone has reversed the fuel gauge and the temperature gauge. At first I thought the fuel gauge didn't work (reads empty but left tank is full) but then realized as you get going the guage climbs to about 1/2 tank when working, 1/4 tank when loafing along. Was there an issue with these machines that they would swap gauges?

    TIA.
     
  2. JoeRagMan

    JoeRagMan LawnSite Senior Member
    Messages: 298

    Do you have the service manual for the mower? I tried doing a web search for a wiring diagram but no luck. As for the blinking charge light, all connections have to be checked to verify that they are clean and tight. Have the connectors for the PTO, key switch, etc been checked? The gauge swap needs to be checked to make sure the correct wires are attached to the correct gauge.Good luck.
     
  3. BigFish

    BigFish LawnSite Fanatic
    Messages: 5,910

    Did ya check the fuse holders? The charging circuit goes thru one of em. Could be loose, corroded, etc.
     

Share This Page