1. Missed the live Ask the Expert event?
    Catch up on the conversation with Ken Hutcheson, President of U.S. Lawns in the Franchising forum plus sign up to receive a FREE eBook on how to grow your landscape business.

    Dismiss Notice

Nebie - Grashopper Transmission Problem?

Discussion in 'Homeowner Assistance Forum' started by fat_angus, Jun 30, 2013.

  1. fat_angus

    fat_angus LawnSite Member
    Messages: 2

    Hi,

    I am not in the industry but use a Grashopper 721D front mount mower and am having problems. I am looking for help.

    Engine starts fine
    Blades turn fine when clutch is engaged


    Problem:

    The mower can no longer move forward. While both lever push forward, the right side doesn't engage with the transmission.

    I am a newbie and not a mower expert. So any feedback will need to be in layman's speak.

    Thanks in advance.
     
  2. goel

    goel LawnSite Member
    Messages: 73

    ...............
     
  3. JCLawn and more

    JCLawn and more LawnSite Fanatic
    from MI
    Messages: 5,222

    You have knuckle joints on your stearing linkage. Pop up the seat and compare the one side with the other. Move the steering lever and if its not moving the valve on the hydro pump something broke. It should be easy to spot what's wrong if you following the linkage.
    Posted via Mobile Device
     
  4. fat_angus

    fat_angus LawnSite Member
    Messages: 2

    Thank you... after thinking it was the right hydro pump - $700.00, I realized that one of the belts was missing in the drive assembly. There is a double pulley off the drive shaft and only one belt. HA! Seems the part will only be about 15 bucks.

    THanks,

    fat_angus
     
  5. JCLawn and more

    JCLawn and more LawnSite Fanatic
    from MI
    Messages: 5,222

    If its the old 721d's the pumps are easy to work on and parts are cheap.
    Posted via Mobile Device
     

Share This Page