New Kohler 25hp runs only on choke.

Discussion in 'Mechanic and Repair' started by mx495, Apr 6, 2006.

  1. mx495

    mx495 LawnSite Senior Member
    from MO
    Messages: 259

    I just put a brand new Kohler CV730 engine on my ztr. Started right up but i can only get it to run on full choke. Will go to full rpms and won't die on full choke either. Take the choke off even just a little and the motor dies. Any ideas?
     
  2. lucforce

    lucforce LawnSite Member
    Messages: 223

    Does the new engine have a fuel pump? Is the fuel tank pickup lower than the carburetor? How old is the gas? Is there a hidden fuel shutoff? Does the engine have an electric fuel shutoff solenoid on the carb? New fuel filter?
     
  3. newz7151

    newz7151 LawnSite Silver Member
    from Tejas
    Messages: 2,419


    I'd say take it back to the dealer you got it from and have em fix it if it's brand new.
     
  4. lucforce

    lucforce LawnSite Member
    Messages: 223

    If he bought an engine an installed it himself, the only warrenty will be on a problem with the engine itself. The problem is likely an issue not with the engine. Eliminate the small things first.
     
  5. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    I agree, Take the whole unit and let them check it out. Ask for a estimate before repair, If it happens to be a warranty problem they will fix it. If they say no warranty least you will know what the problem is so you can fix it yourself and save shop labor.
     
  6. mx495

    mx495 LawnSite Senior Member
    from MO
    Messages: 259

    There is a solenoid for fuel shutoff and i tried disconnecting it, didn't help. New fuel filter, new fuel pump. Carb is getting gas and i t is fresh gas. Is there something i am missing? It is pretty simple to hook up, i have done it other times with no problem???? Basically plug in the wire harness, hook up choke and throttle cable???
     
  7. Restrorob

    Restrorob LawnSite Fanatic
    Messages: 11,029

    First thing I would do is touch the fuel shut-off solenoid in my fingers and turn the key on and off feeling for a click, If so it is working. The next thing is the main jet in the carb., It's possible trash or something was left in the carb. during assembly and clogged the jet.
     
    KyBluGrass and hort101 like this.
  8. lakewood2

    lakewood2 LawnSite Member
    Messages: 6

    Hey - if you tried disconnecting it and it did not "help" maybe that is it because I believe it is a normally closed valve. It should have been even worse when you disconnected it. I would start there! Something else though...maybe some evaporated fuel residue might have blocked or partially blocked a passage. This seems to be more common with the fuels today than it used to be. One way to know if that might be more likely is to look at how long ago the engine was built or how long ago it was last run. If the engine was not run since built then look at the serial number. Add 70 to the first two digits to determine the year it was built (and possibly last run) and the next three digits are the day of that year it was built.
     
    FromUndaChz likes this.
  9. Tsmithstur

    Tsmithstur LawnSite Member
    Messages: 1

    I also have this same issues but haven't had any luck finding the solution
     
  10. FromUndaChz

    FromUndaChz LawnSite Member
    Male, from Connecticut
    Messages: 118

    Disconnecting it won't work.. It's normally closed and is opened when given 12V. Take it out and put it on the battery and make sure it clicks open with a solid click. If it's weak, cut the end off the solenoid leaving just the threads. Put it back in the hole and leave the wires off. We have a mower that keeps making the solenoid go bad, I just cut the end off it and put her back in, we haven't had an issue since. When we had this issue, it only ran with choke. If you don't want to ruin the solenoid just for testing purposes, I think it's just a pipe thread so you might be able to stick a plug in there. Make sure you match the threads or you'll need new parts.
     

Share This Page