plate compactor problem

Discussion in 'Hardscaping' started by bigviclbi, Mar 29, 2009.

  1. bigviclbi

    bigviclbi LawnSite Senior Member
    from nj
    Messages: 900

    Saturday afternoon after a long day of tamping after a winter of sitting my stone plate compactor was running fine but would not move forward, kind of staying in one spot. Changed air filter and checked oil seemed fine. now this tamper is about 5 years old and I have never done anything besides air filter and spark plugs. Could it be the belt is loose/worn? What actually drives the plate compactor forward?
     
  2. NEUSWEDE

    NEUSWEDE LawnSite Bronze Member
    from Maine
    Messages: 1,147

    did you check the plate and make sure it was clean and didn't have anything sticking to it. I know mine wont go if stuff is stuck to the bottom, uually have to flip it over and scrape off with a shovel.
     
  3. Rex Mann

    Rex Mann LawnSite Senior Member
    Messages: 621

  4. Bru75

    Bru75 LawnSite Senior Member
    Messages: 582

    Was it still vibrating as much as usual? If not it's probably your belt slipping.
     
  5. GreenLight

    GreenLight LawnSite Senior Member
    Messages: 519

    I had the exact same problem and like everyone is saying, it turned out to be the belt. Of course in my situation it became obvious when the machine started spitting chunks of the belt out like shrapnel.
     
  6. btammo

    btammo LawnSite Member
    Messages: 98

    yep loose belt.
     

Share This Page