1. Can’t make it to the GIE+EXPO 2017?
    LawnSite brings the trade show floor to your fingertips with our new GIE+EXPO 2017 Sneak Peek video series debuting now in the Lawn Mowing forum.

    Dismiss Notice

Problems with Exmark Ultra Vac

Discussion in 'Mechanic and Repair' started by premierlawncaremi, Sep 2, 2012.

  1. premierlawncaremi

    premierlawncaremi LawnSite Member
    Messages: 58

    I had my impeller bearings go out about two weeks ago so I replaced them. two days later it started getting loud again so I checked and there was some slop so I replaced both bearings once again. A couple days later it started to get loud AGAIN, what could possibly be wrong?? Am i doing something wrong when I replace them? Any help is greatly appreciated!
     
  2. premierlawncaremi

    premierlawncaremi LawnSite Member
    Messages: 58

    Anyone?
    Posted via Mobile Device
     
  3. sgrenier24

    sgrenier24 LawnSite Member
    Messages: 69

    One of my ultra vacs had a bent impeller that resulted in a vibration and an awful noise.
    Posted via Mobile Device
     
  4. premierlawncaremi

    premierlawncaremi LawnSite Member
    Messages: 58

    I thought it could be something to that affect but when I replace the bearings the noise stops for a couple days...did yours do the same?
     
  5. american dream

    american dream LawnSite Senior Member
    Messages: 317

    Sounds like a out of balance impeller is ruining new bearings
    Posted via Mobile Device
     

Share This Page