redmax eb431

Discussion in 'Mechanic and Repair' started by crs, Sep 13, 2001.

  1. crs

    crs LawnSite Member
    Messages: 121

    I have a Redmax eb 431 that I use a back up blower. Recently it developed a couple of problems. It surges at full throttle. It will start and run fine for just a couple of seconds and then it drops several hundred rpm and goes back and forth untill you pull the throttle back a little. It will run fine at 3/4 throttle. Also, it leaks fuel out of the vent hole in the cap. It is not a just a dribble. If you slosh the fuel around in the tank, like you would when walking with it on your back, fuel spits out the vent about an inch and a half.

    The spark plug, air filter and fuel filter are all new. The carburetor is not adjustable.

    The fuel cap has been replaced with two different styles of cap. One works better than the other but they both leak.

    Thanks for any input
  2. vipermanz

    vipermanz LawnSite Bronze Member
    Messages: 1,773

    im going to say it's your spark arrestor
  3. Keith

    Keith LawnSite Gold Member
    Messages: 3,979

    I'll agree with vipermanz, check that first. If that fails, replace your fuel lines. Beyond that you are probably looking at a carburetor or a rebuild kit at the least.
  4. Fish

    Fish LawnSite Member
    Messages: 139

    Does your carb have a primer bulb?
  5. Cleve

    Cleve LawnSite Senior Member
    Male, from Rockmart, GA
    Messages: 404

    We have two of these. Did have three but someone lifted one off the back of the truck at a customers a year ago.
    I'm having some of the same problems with poor performance right now on one. I'm going to check the exhaust as suggested.

    Regards the fuel problme, all of ours have had the same problem. And, the dealer has been able to do nothing for them. Replaced the caps more than once. Won't do it all the time but is a problem. I believe Redmax has a fuel cap problem related to how the rubber seal fits against the top of the filler neck on the tank. One of the men at the dealer finally told me that many were doing this and the only real fix had been to be careful to make sure the rubber seal is seated all the way into the cap and to only screw the cap on "softly". Do not attempt to tighten the cap really tight. Seems to help more than anything else.
  6. Jason Pallas

    Jason Pallas LawnSite Bronze Member
    Messages: 1,335

    Crs - I have alot of experience with these blowers - we've got about 20-25 of them and that's all we run. Unfortunately, the carbs/fuel systems can be real fickle. If it's the newer style (last 4 years or so) there's no low/high speed idle adjustments on the carbs. This can be a bummer - as once the carb begins to wear, you can't adjust it out and simply have to replace it. I would check your throttle cable system and make sure there's no play there. If that's good, you may want to take the carb apart and clean it. A little piece of dirt stuck in the wrong place could cause a lot of problems. Finally there are two fuel filter systems, one on the pick-up line in the tank and one in the carb (small screen in fuel basin). The filter in the tank can be taken apart and cleaned instead of replacing. Because you said you replaced it, I'd assume that wasn't your problem. - However, these models are infamous for creating fuel pressure vaccums. This sounds like your problem - except, your cap is leaking - so it's unlikely that you've got a vaccum problem. (we've got one unit that runs great but every 20 minutes you need to crack/open the cap to release the vaccum or else the fuel system shuts down. Hopefully some of these hints will send you on the right direction. Good luck
  7. Fish

    Fish LawnSite Member
    Messages: 139

    Does it have a primer bulb?
  8. robertobradley70

    robertobradley70 LawnSite Member
    Messages: 1

    Hello everyone,

    I think I know the problem here but I need a second set of eyes on it. I have a 12 year old Redmax EB431 which has been running fantastically until today (starts on first pull, has good power, no smoke, good compression).Today I started the blower, it ran for about 2 seconds and then just died.

    I checked for spark - nothing. The resistance on the secondary coil is about 2k ohms. The resistance on the primary coil (they're physically separate coils on this unit) was around 53m ohms. I took the kill switch out of the picture to make sure that wasn't malfunctioning - still no spark. I took a look at all of the wiring and noticed that the plug wire has a pretty deep gouge in it - deep enough to expose the conductor - but it still conducts electricity. I tried putting the spark plug on a known-good machine (a power washer with a Tecumseh HM80) and it produces a good spark.

    At this point, I'm thinking I should replace the secondary coil (if for no other reason to replace the spark plug wire). I couldn't find any coil testing procedures or specifications online and I'd like to get the opinions of some people that see these things every day (or at least in the past have seen them every day). Not only that, but the primary coil is like $75 and the secondary is $50. I don't want to blindly replace parts.

    Is there anything else I should try before I replace the secondary? The engine is completely off the blower right now and is fully accessible.


Share This Page