Scag runs 2 minutes and cuts off

echo8287

LawnSite Member
Location
Ga
I am needing some help. I have a 2010 Turf Tiger SST52V-27CH with a 25hp Kohler command pro engine CH740S-0041.I keep it in the basement. No Problems since new.Got it out the other day, drove it up a hill to cut the grass and it cut off. Started up ran about 5 seconds and died. So I thought trash in tank, I drained gas tank, bushing in gas tank was leaking(maybe dry rotted) So here's what I found so far>
1. The black bushing had torn and was partially covering the opening of the metal fitting. (I thought I had found the problem>nope)
2. Replaced the fuel filter and found gas line cracked(thought that must be it)>nope
3.Took off carb solenoid and cleaned area was greasy dirty, Checked solenoid operation was good
4. New spark plugs
5.Found no power to carb solenoid>fuse blown> replaced fuse
6. Replaced air filter
7. Loosened gas cap
8. Sprayed linkages and tightened cables
9. Now it starts runs about 2 minutes then the linkage to the bottom of the carb starts moving and it cuts off. I am guessing it like the carb accelerator pump and linkage on both sides of the bottom of the carb.

Don't know if the solenoid gets weak and closes, I hate to cut the plunger off since it does work. If there was a way to plug the hole I could remove it and try that but the flat plate on the back of the solenoid and 2 screws is what seals the back of the solenoid.
Got any suggestions what to try next?
Any ideas on what I could check next?
 

Smokindog

LawnSite Senior Member
Location
DFW area
Try going a step further and removing the gas cap. I've got a Honda 5+ HP where loosening the cap wasn't enough and once I bought a new one the problem was solved. As to the carb/solenoid. I've had to replace mine a couple times on my V-Twin but it's been MUCH better since I've taken to using the "2 year" quantity for fuel stabilizer AND turning off the fuel valve and running the gas out after using it for the day. I haven't gone to ethanol free simply because this seems to be working and it's 1/2 the cost!!!! Also, something I never realized until recently, the manual for my engine (consumer) says to make sure to idle the thing down for 30 seconds before shutting off. Not saying that has anything to do with the price of butter but it was new to me and I'm an old fart :)
 
OP
E

echo8287

LawnSite Member
Location
Ga
I tried it without the cap still the same. The gas was new and it was ethanol free, thats all I put in lawnmowers, weed eaters, log spliter, boat motor. I am going to jump out the solenoid next and see what happens.
 
OP
E

echo8287

LawnSite Member
Location
Ga
Ok today I jumped out the carb solenoid with some alligator clips and it still runs maybe 45 seconds, then the linkage on the bottom of the carb starts moving and it cuts off. Any suggestions? Thanks
 
OP
E

echo8287

LawnSite Member
Location
Ga
I am still fighting with my Turf Tiger. I took the carb off and cleaned everything with carb and brake cleaner and blew air thru all the little passages. Re-installed and it runs a tad longer> but then the butterfly and linkage on the bottom of the carb attached to the accelerator pump starts to move and it cuts it off. What is making this linkage throttle the engine and shut it off? Anybody got any suggestions?The carb is a Kekhin 056 22 78B one barrel.Thanks for all the replies thus far.
 

dieselss

LawnSite Silver Member
Location
NWI....
While it's shutting off, shoot some carb cleaner and see if it stays running .

Is the fuel filter always showing fuel?
 

SouthEastTurf

LawnSite Member
Location
Macon GA
I am still fighting with my Turf Tiger. I took the carb off and cleaned everything with carb and brake cleaner and blew air thru all the little passages. Re-installed and it runs a tad longer> but then the butterfly and linkage on the bottom of the carb attached to the accelerator pump starts to move and it cuts it off. What is making this linkage throttle the engine and shut it off? Anybody got any suggestions?The carb is a Kekhin 056 22 78B one barrel.Thanks for all the replies thus far.
the linkage is from the governer, it's opening the throttle because the RPM is dropping.

The throttle controls on the mower don't directly control the throttle, they control the governer which keeps the engine running at a steady rpm, no matter the load., the govener controls the throttle and trys to keep the motor at the correct RPM.

Sounds like its running out of fuel, . You have replaced the all the fuel line? The line can flake and swell to where it will not flow enough fuel to keep the engine running.
 
OP
E

echo8287

LawnSite Member
Location
Ga
I took the carb off again and re-cleaned everything. Saw a video on the carb and found a couple of other places to clean.You might be right about the fuel.(Southeastern turf) The lines are all good have been blown out and I've turned it over and let it pump gas into a coke bottle.It did not pump a lot of gas out the line, just a half ass stream. Cleaned all and put it back on the mower.Ran a bit longer and then started to quit again the lower linkage or governor is cutting it off. should the float bowl be about half full of fuel when you take the top off the carb? I don't think it had mush fuel in the bowl. Possibly the fuel pump? It has a new fuel filter and the connection on the tank is new.
 

Top Forums



Top