TC2 Hydro belt/engine moving

Skol

LawnSite Senior Member
Location
The Ozarks
Had a Hydro belt break on my Tiger Cat 2 last night. It happened while my daughter was moving it to the shop. The belt was obviously broken, but what I found odd was that the motor was turned a little, and could easily be rocked back and forth.... I've never had a Hydro break on a Scag, would that be normal?
 

JoeRagMan

LawnSite Senior Member
Location
Near TMI
Might want to check the engine mounting bolts. I repaired a mower that all four bolts had fallen out, engine was just sitting in the frame.
 

ktoom

LawnSite Senior Member
Location
Northe East
Had a Hydro belt break on my Tiger Cat 2 last night. It happened while my daughter was moving it to the shop. The belt was obviously broken, but what I found odd was that the motor was turned a little, and could easily be rocked back and forth.... I've never had a Hydro break on a Scag, would that be normal?
My brother in law had this happen to his TC II as well. They broke a few drive belts when the mower only had a few hundred hours on it. Then he took the mower to the dealer recently and they discovered that the engine had loosened up on the frame.

Oddly enough, then engine blew up a few days after he got it back from the dealer. It was the 25/26hp Kohler efi and it had only 800hrs in it. He brought the mower back to the dealer and they found the bottom crankcase cover was cracked and leaked all the oil out. After jt lost al the engine all, all hell broke loose in the engine. No way to prove if it was the dealers fault or if it was something caused by the loose engine.
 

Wolfgang

LawnSite Member
Location
Ireland
I agree with above we had this happen and it was the engine mounts which had split in two, they looked fine until we put a pry bar in and lifted the engine, replaced all 4 and it sorted the issue.
 

Top