Toro Z Max

Discussion in 'Pesticide & Herbicide Application' started by Hogjaw, Jun 6, 2008.

  1. Hogjaw

    Hogjaw LawnSite Senior Member
    Messages: 386

    Yes, I know this has nothing to do with fert / squirt, but my problem is tonight I loaded up and when I pulled up park brake the engine died (didn't turn off key) Acts like no battery now.

    Switch on brake is plugged in and all leads seem to be tight.

    Any ideas?

    Whatever you do, don't go to the mowing section and ask this question! They must be kids there.
  2. AustinLawnscape

    AustinLawnscape LawnSite Member
    Messages: 75

    I had a similar problem with my Exmark. The PTO switch died. It worked fine when the switch was replaced.
  3. Hogjaw

    Hogjaw LawnSite Senior Member
    Messages: 386

    The on / off I hope your talking about and not the electric clutch (replaced one at nearly $230.00).

    Thanks for your response.

    Take care.
  4. Runner

    Runner LawnSite Fanatic
    Messages: 13,497

    Were your handlebars open? If they are closed, and you hit the brake, the engine kills out.
  5. Hogjaw

    Hogjaw LawnSite Senior Member
    Messages: 386


    Turned off ignition, checked to make pto was not engaged, stood up, checked bars (open) and nothing. Left it on trailer tonight (glad it happened loaded)
  6. FdLLawnMan

    FdLLawnMan LawnSite Bronze Member
    Messages: 1,251

    There is a switch somewhere near where the parking brake pivots. Take the wires off the switch and try it. If that doesn't work connect the wires together somehow. If it doesn't work then there is a problem somewhere else in the interlock system.

    LIBERTYLANDSCAPING LawnSite Bronze Member
    from Indiana
    Messages: 1,283

    Sounds like a handlebar switch. All if fine untill you go to put park brake on. then won't restart, just like an Exmark I had. Try wiggling each handlebar while trying to start engine, that always worked for me-mine was just sticky.
  8. Hogjaw

    Hogjaw LawnSite Senior Member
    Messages: 386

    Thanks...............wiggled right bar and starts.............looks like it will be a major job just to get to the switch since I can't see it.

Share This Page