Trailer brake lights not working

RollTide

LawnSite Member
Location
Daphne, AL
I have a 2002 2500 HD 6.0. Has factory tow package and wiring with 7 pin connector and then to 4 pin for the trailer. When I hook up my utility trailer the turn signals and running lights work but no brake lights. All lights work on the truck and I've found no blown fuses in the dash or under hood fuse box. The only thing that doesn't work on the truck right now is the emergency flashers. Anybody have a solution? I can't be the only one with this problem. Thanks in advance for any help and suggestions.

Thanks,
Steve
 

southerntide

LawnSite Fanatic
Location
Alabama
Could be bad module had to swap mine out a couple months ago, may need to replace it with new T connector
 

windflower

LawnSite Bronze Member
Location
wilmington nc
The flashers and brake use the same filament in the light bulb. I'd check the 7 pin connector and make sure you are getting power to it with the brakes on. Are you using a commercial adapter? Some are wired differently than others. If you have power to the brake wires on the 7 pin make sure the 4 pin also has power to the brake lights. You can also check the trailer wiring by supplying power to the brake light wires at the connector on the tongue of your trailer and see if the brakes come on. I'm betting you have the wrong adapter.
 
OP
R

RollTide

LawnSite Member
Location
Daphne, AL
I'm getting power to the 7 pin connector except for the brakes. It has me stumpified!

southerntide, is this module above the spare tire and ties in to the wiring harness?
 

southerntide

LawnSite Fanatic
Location
Alabama
Yes is a square or rectangle black box module you are looking at? Mine did the same crap replaced it and went ahead rewired my trailer with fresh wiring while I was at it but it was the module that went bad.
 
OP
R

RollTide

LawnSite Member
Location
Daphne, AL
Well I guess I'll try replacing that. Will an auto parts store have it or do I need to look at an accessories/towing type place? Thanks for the help man!
 

southerntide

LawnSite Fanatic
Location
Alabama
I bought mine at advanced auto, I tested mine before seemed fine narrowed everything else down and just replaced it not sure what was bad in it but was the module hooked it right up and worked perfect on old trailer wiring then rewired it after.

I'm pretty positive that is your issue, I did do a check of my trailer wires to make sure none were grounding out wore through though.
 

Top Forums



Top