1. Missed the live Ask the Expert event?
    Catch up on the conversation about fertilization strategies for success with the experts at Koch Turf & Ornamental in the Fertilizer Application forum .

    Dismiss Notice

Truck issues, need help

Discussion in 'Heavy Equipment & Pavement' started by Albery's Lawn & Tractor, Jun 19, 2012.

  1. Albery's Lawn & Tractor

    Albery's Lawn & Tractor LawnSite Bronze Member
    Messages: 1,674

    I have a '03 Dodge 3500 w/ 5.9 cummins, truck has 150K miles. Truck now seems to have no power, can't pull an empty trailer without wanting to over heat. New transmission, flushed radiator, new water pump and thermostat, no check engine light. No oil in the turbo intake. Any thoughts of what this might be?
     
  2. Tizzy

    Tizzy LawnSite Senior Member
    Messages: 383

    fuel system issue? did you do any diagnostics on the fuel system.
     
  3. AEL

    AEL LawnSite Bronze Member
    Messages: 1,724

    Check your lift pump.
    Posted via Mobile Device
     
  4. Albery's Lawn & Tractor

    Albery's Lawn & Tractor LawnSite Bronze Member
    Messages: 1,674

    But would the lack of fuel cause the truck to want to run hot?
     
  5. turboawd

    turboawd LawnSite Member
    from midwest
    Messages: 236

    did an intake boot pop off by chance?
     
  6. bobcat_ron

    bobcat_ron LawnSite Fanatic
    Messages: 10,137

    Head gasket or thermostat?
    Posted via Mobile Device
     
  7. AEL

    AEL LawnSite Bronze Member
    Messages: 1,724

    Caused my 06 to run hot . Installed an aftermarket fass150 and it was way better , not to mention way better filtration.
    Posted via Mobile Device
     
  8. LuckyFlyinROUSH

    LuckyFlyinROUSH LawnSite Member
    from MO
    Messages: 36

    Sounds like major boost leak. PSI normal? Fuel pressure good?
     

Share This Page