• Online Events For Landscapers!
    With GIE+EXPO cancelled, virtual education and product launches are filling up the fall. Check out dates for Caterpillar, Exmark, NALP, and more. Click here to learn more.

turf tiger problems

brianslawncare

LawnSite Senior Member
i have a turf tiger 27hp kawaski liquid cooled. and im having problems with the battery not staying charged. after 5 or 6 yards the battery goes dead i change the battery and im good to go. just on friday i got 9 yards in and my last yard it died. and on one occasion it lasted all day? it happened last year only for a day or two then it was fine. i checked all connections and cant find anything. i contacted scag itself and the rep said to contact kawaski. anyone have any ideas? thank you for the help. brian:cool2:
 

puppypaws

LawnSite Fanatic
i have a turf tiger 27hp kawaski liquid cooled. and im having problems with the battery not staying charged. after 5 or 6 yards the battery goes dead i change the battery and im good to go. just on friday i got 9 yards in and my last yard it died. and on one occasion it lasted all day? it happened last year only for a day or two then it was fine. i checked all connections and cant find anything. i contacted scag itself and the rep said to contact kawaski. anyone have any ideas? thank you for the help. brian:cool2:
Put a tester on the battery and see if your alternator is putting current back into it. I feel assured your alternator is not charging the battery properly, let us know what you find.
 

twj721

LawnSite Senior Member
Location
North East Texas
Mine did the same thing at the start of the season and The charging circuit fuse had blown so I put another one in it did the same thing I fianly putt he battery on a slow charger overnight and Have not had any problems since who knows ? I think mine the batteryu was low from the sitting all winter and it was just too much for the charging circuit Hope this helps I also thought batterty was bad so i tested it and it came back good but needed to be charged .
 

Stillwater

LawnSite Platinum Member
i have a turf tiger 27hp kawaski liquid cooled. and im having problems with the battery not staying charged. after 5 or 6 yards the battery goes dead i change the battery and im good to go. just on friday i got 9 yards in and my last yard it died. and on one occasion it lasted all day? it happened last year only for a day or two then it was fine. i checked all connections and cant find anything. i contacted scag itself and the rep said to contact kawaski. anyone have any ideas? thank you for the help. brian:cool2:
Let me get this stright,
your battery is not chargeing and you cant figure it out. so you go the the dealer rep for help, He blows you off and tells you to call kawi?

Well I just crossed off scag mowers on my list for new mowers to consider. I suggest you do the same, My equipment feeds my family and and is required to survive. I need a dealer to stand behind me not pass the buck. He could have at the least mentioned any one of these reasons listed below,

1) bad ground wire on the coil
2) voltage regulater.
3) bad rectifier
 

Rocco Evangelista

LawnSite Member
Location
sunbury, Ohio
I have the exact same issue as Brian. Battery seems not to charge. I had the battery checked but it is ok. I jumped the mower, the starter engaged but would not turn over. When I do not jump, it does nothing. Fuel pump is working so I know it is getting power. I checked the fuses and safety switches. Has been doing this for some time now. Any ideas??
 
Top