LawnSite Member
Well, with the last lake effect snow (about 7") around Chicago (using Midway Airport) we just broke December snowfall record for most snow in the month of Decemeber $$$$.

Of course, now, I am having a problem. I have the Fisher EZ-V 8.5' plow and I am having problems with the controller (AKA: Fish-Stik). The unit is not "lighting" up getting power for some reason. The unit is "turned on", I checked and replaced the fuses and all connections (3 of them) on the front harness are connected. The weird thing is no power is going to the controller. Then without doing anything and sitting idle for 30 mins. or so the controller will light up and be working again only to go out after about an hour. I am guessing maybe somehow the harness connections are getting wet inside? and I use deelectric grease on them (actually they are smoothered with delectric grease). Could too much delectric grease cause this.

If anyone has had similar problem and/or any suggestions it would be much appreciated. With all the snow here it is going to be hard to get it in for service and I ma hoping (really really hoping) it is something very simple that I am overlooking and/or can correct myself. Thanks .... ED

SlimJim Z71

LawnSite Senior Member
Just a shot in the dark here, but try moving the cable around. Is it possible that the wire inside the insulation is broken??? Only reason I'm saying that is because my Highlighter went out the other day, I jumped up there and startted tugging on the wires, and it lit up again. Re-did the connection, and I have lights again.



LawnSite Member
No not yet. Tried your idea no cigar. Taking it in first thing in the morning (1-02). As you proably know calling for snow here on Wed. (doesn't look like much) and possibly a nicer size one on Thurs. I am actually getting nervous that this problem won't be solved by then. I already have a couple of my "call when you need me" fellow plowers on board just in case if I need to sub-contract some work to them this week.

Busted my butt and plowed my #@* off to keep all my accounts happy. Not going to loose them now! I'll keep you posted.

.. ED


LawnSite Member
Nova Scotia
You likely got it fixed by now, but here's how to test the Controller.
1. Make sure the pump motor, and motor relay are working.
This is done by using a jumper cable from the battery
directly to the positive post on the motor , the relay is tested by connecting a jumper wire across the relay secondary terminals the motor should run.

2. At the 14 pin connector check to see if pin #8 has 12v with the ign on, if not verify the vehicle power source and 10a fuse, if the controller is not lighting up this is the likely problem.

3. The test for the printed circuit board in the controller isn't recommended unless you know what your're doing because you can fry it VERY easly, if you have a buddy & an EZ-V just switch controllers and see if that works, I presume where you said you checked the fuses, you talking about the two in the controller itself. The controller should still light up if 1 is blown.



LawnSite Member
THANK YOU to all who responded to my problem.

Sorry it has taken me so long to let you guys know what was wrong.

When I took it in, they found a loose wire up in the dash to the fuse box. Something very simple. I actually probably could have done it myself but oh well.

Thanks to all again.......... ED