1. Missed the live Ask the Expert event?
    Catch up on the conversation about fertilization strategies for success with the experts at Koch Turf & Ornamental in the Fertilizer Application forum .

    Dismiss Notice

Vermeer Trencher Hydraulic Issues

Discussion in 'Mechanic and Repair' started by DumasWalker, Dec 1, 2018.

  1. DumasWalker

    DumasWalker LawnSite Bronze Member
    Male, from Birmingham al
    Messages: 1,305

    I have a 2007 RT100 Vermeer Trencher I am working on. It has two stacked pumps.The front pump directly off the engine. Has the suction line then sends pressure to valve body controlling lift arm and chain drive motor. From the valve body fluid then goes to cooler then the filter before it goes into tank some fluid goes into 2nd pump Hydro gear used only for drive wheels, then goes back to tank.
    I have dealt with many Hydraulic issues before with equipment this is the first Vermeer trencher I Have worked on. The chain and lift arm work great, the drive wheels do not at all. Fluid looks great until about 3 minutes of running it foams then foams out of tank with or without cap on. With hydro gear pump off fluid still does this running just one pump. I think the hydro gear is good it's fluid is full of air so that why it does not work. Suction line looks good, I have never seen one pump cause this much foam it makes no unusual noise.
     
  2. Walker56

    Walker56 LawnSite Silver Member
    Messages: 2,278

  3. DumasWalker

    DumasWalker LawnSite Bronze Member
    Male, from Birmingham al
    Messages: 1,305

Share This Page