Z_spray problem

Discussion in 'Pesticide & Herbicide Application' started by jimjohn1, Jul 7, 2010.

  1. jimjohn1

    jimjohn1 LawnSite Member
    Messages: 25

    Need some help---Got a brand new z-spray interm. After 1 hr of use spraying three way product and 5 gals left :hammerhead::hammerhead: in the tank started having a problem. No pressure. Called LT Rich and left a message on saturday. Today is Wed. No call yet. Anyone have any Ideas. I checked filter and all valves but no luck. Thanks
     
  2. grassmasterswilson

    grassmasterswilson LawnSite Fanatic
    from nc
    Messages: 5,175

    might try to tighten all the fittings. sometimes they are loose and will suck air instead of water. call LT again. they are always pretty good about getting back and helping solve the problem.
     
  3. OP
    OP
    jimjohn1

    jimjohn1 LawnSite Member
    Messages: 25

    Thanks for your help. I will do some more checking.
     
  4. RigglePLC

    RigglePLC LawnSite Fanatic
    Messages: 15,607

    Is the problem electrical? Fuse good? Is the pump actually running? Wilson's comments are good--there is a chance the pump has lost prime--air in the system. Is the fluid recirculating back into the tank? Did you check for clogged filter screens at the nozzles? Clean them to be sure .
     
  5. GreenAcresFertCo.

    GreenAcresFertCo. LawnSite Member
    Messages: 139

    Check the fuse if the pump isnt running at all, but then again, the electric start doesnt work if the fuse is popped
     
  6. Grandview

    Grandview LawnSite Gold Member
    from WI
    Messages: 3,251

    Checklist. Make sure valve from the tank to pump is open. Make sure pump runs. If yes for both open the pressure relief valve completely and run pump. You might have air trapped in the line. Close prv until desired pressure. Good luck. It is not a complicated system.
     
  7. rcreech

    rcreech Sponsor
    Male, from OHIO
    Messages: 6,183

    I agree with Grandview. If a system isn't spraying there can ONLY be a few things wrong. Spray systems are as easy as it gets.

    Here is the way I would handle this situation.


    If you called on Saturday and they have not returned your call...maybe you should call them back as they may not have gotten your message.

    If I were broken down...I would have called them on Monday morning until I got them.

    Their customer service is excellent, so I would give them a call.
     
  8. OP
    OP
    jimjohn1

    jimjohn1 LawnSite Member
    Messages: 25

    Andy called me yesterday and he helped me out. The message I left was with service and I think the person was on vacation. But anyway Andy was great. My first experience with LT Rich turned out like I thought it would---Great. Andy knows the machine inside and out like I have always heard. This machine is well built does everything that I thought it would. Thanks everyone for your responses.

    The problem I had was the blue valve lower left on the machine (turned wrong direction so it was pumping from the 7 gal tank) Now that Andy familiarized with the valves shouldn't be a problem.
     
  9. br549oicu8

    br549oicu8 LawnSite Bronze Member
    Messages: 1,230

    Glad you got it all figured out. Andy has always been helpful, even when we do some dumb stuff!! LOL! He does know every inch of those machines for sure!!!
     
  10. kbrashears

    kbrashears LawnSite Senior Member
    Messages: 776

    I have a Z-Spray problem.

    I just picked mine up and it's raining.

    This thing is a BEAST.

    Fired right up out of the crate, backed it out and drove onto my TRAILER and hauled her home.

    It's way too early in the process, but this thing just screams quality and solid fabrication.

    Max with aux tank, foam marker.
     

Share This Page